Engine Fxs V1.1

On Sale! by Motion Dreams in Modifier Setups


Do I need Blender 3.6 to use these effects?

Effects included in version 1, can be used in Blender 3.5x and above.

New effects(5 effects and 1 preset) which were added in the v1.1, use Simulation Nodes. Hence You need 3.6x and above to use them.

Do I need a good knowledge on geometry Nodes to use this pack?

No, You can just drag and drop presets and tweak their sliders. However, if you want to create your own using "Building Blocks", Just a decent understanding of geometry nodes will be helpful.

Can I create my own Engine FXs using this pack?

Yes, Absolutely. Apart from the presets this pack provides you everything you need to create your own FXs. Which we call "Building Blocks".

Sales 300+
Customer Ratings 5
Average Rating
Dev Fund Contributor
Published 12 months ago
Blender Version 3.6, 3.5
License Creative Commons
Have questions before purchasing?

Contact the Creator with your questions right now.

Login to Message